Have an XBOX 360? Has it broken?

Discuss games.
User avatar
Tony
Posts: 1152
Joined: Sun Apr 11, 2004 7:14 pm
Location: Vancouver, BC
Contact:

Have an XBOX 360? Has it broken?

Post by Tony » Mon Oct 29, 2007 10:53 pm

I don't have an XBOX 360, but with the excellent roster of games it's accumulating, it's looking more and more inevitable that I pick one up. Sad thing is, almost everyone I know who has one has had to send it back in due to the Red Rings of Death.

Anyone out there NOT have their 360 break on them?

(Knock on wood)

User avatar
SonOfaRich
Posts: 676
Joined: Mon Dec 22, 2003 1:43 am

Post by SonOfaRich » Mon Oct 29, 2007 11:32 pm

It happened to my brother's XBOX 360. I was playing Rainbow Six Vegas then all of a sudden THE RED RING OF DEATH appeared. The worst part was his warranty had expired, so he had to pay for it to get fixed!

I hear the new 360's shouldn't have that problem though.
Intergalactic proton powered electrical tentacle advertising droids!!!!!

User avatar
Kazu
Site Admin
Posts: 9337
Joined: Tue Aug 19, 2003 8:59 pm
Location: Seattle, WA
Contact:

Post by Kazu » Tue Oct 30, 2007 1:41 pm

It's happened to about a third of the people I know who have 360s. Mine's been running okay so far, but I only bought it at the time BioShock came out, so it's pretty new. I'll keep you posted...
Image
Image

User avatar
SonOfaRich
Posts: 676
Joined: Mon Dec 22, 2003 1:43 am

Post by SonOfaRich » Wed Oct 31, 2007 11:14 pm

It should be fine then. It BETTER be!
Intergalactic proton powered electrical tentacle advertising droids!!!!!

User avatar
Scott Hallett
Posts: 403
Joined: Wed Sep 06, 2006 6:59 pm
Location: Toronto
Contact:

Post by Scott Hallett » Thu Nov 01, 2007 7:57 am

I've read that the newer sku's are far more stable, so you should be ok if it's relatively new. The warranty's been extended to 3 years as well, so that helps.

User avatar
flatrabbit
Posts: 21
Joined: Fri Nov 02, 2007 10:02 am
Location: Kirkland, WA (just NE-ish of Seattle)
Contact:

Post by flatrabbit » Fri Nov 02, 2007 10:14 am

I picked up a 360 about a year after launch in hopes that the bugs would be worked out but 4 months later I got the red ring of death. The bonus is that customer service was pretty helpful and it only took me 6 days to send in and receive my fixed 360 with a nice month of live for my trouble.

was I upset about the loss of the machine? yeah, it could have been at a better time (right when the halo 3 beta started). But I was satisfied with the return time at least.
flatrabbit
--"We are all in the gutter, but some of us are looking at the stars." - Oscar Wilde
‡ [ home ] ‡

User avatar
Finnegan
Posts: 246
Joined: Thu Feb 19, 2004 3:40 am
Location: Bay Area, California
Contact:

Post by Finnegan » Sun Nov 04, 2007 12:27 pm

i bought mine on launch day, and it died when i was playing some viva pinata earlier this year. I sent it in, and ever since it's been doing fine. I'm kinda glad that i got the (hopefully only) red ring of death out of the way

Stick
Flight Moderator
Posts: 1267
Joined: Wed Dec 03, 2003 2:20 pm
Location: Toronto

Post by Stick » Thu Nov 08, 2007 5:02 pm

currently on my 3rd xbox.. and even that one is starting to make strange noises.. i just hope that if it choses to die, it's still while i'm near the vicinity of where i can still get it serviced.

User avatar
Phil
Posts: 1672
Joined: Sun Aug 24, 2003 7:29 pm
Location: Los Angeles
Contact:

Post by Phil » Tue Nov 13, 2007 5:42 pm

I haven't had any problems with mine in the year or so since I bought it.
It overheated or something once, and stalled out, but came back to life after a while.
No red rings of death.

Except for the red rings of death under my eyes after the occasional late-night Halo 3 binge.

:shock:

8)

User avatar
Scott Hallett
Posts: 403
Joined: Wed Sep 06, 2006 6:59 pm
Location: Toronto
Contact:

Post by Scott Hallett » Wed Nov 28, 2007 10:13 am

I've got a weird issue. Playing Assassin's creed last night, all of the alternating textures on screen start flashing on and off (with some regularity). If I reboot, anything I get the same thing in the game. Popped in Halo 3 and it seemed to be fine.

However, every third time I take out Assasin's creed it's either small blocks all over the dashboard or an error message (E74 - Something about the AV cable or GPU) and 1 red light.

Really annoying, and bad timing...Assassin's Creed is really good!

User avatar
elisio
Posts: 262
Joined: Tue Jun 21, 2005 1:21 am
Location: Paris, France
Contact:

Post by elisio » Sat Jan 05, 2008 8:29 am

i have a 360 since November and so far it's doing fine. no RRD or anything. no problems with the games either. haven't played Assassin's Creed but it's a pretty buggy game from what i've seen on some related forums.
my cousin's console died 2 months ago though. and i have a friend who's 360 only lasted 15 minutes once set up and while playing Gears of War.
i keep my fingers crossed.

Brendan
Posts: 7
Joined: Tue Sep 18, 2007 9:18 pm
Location: Redmond

Post by Brendan » Wed Apr 09, 2008 6:42 pm

My Xbox 360: July 24th 2007 - April 09 2008 (RRoD).

No Halo 3 for three+ weeks, just bought CoD4 last weekend too :(

Stick
Flight Moderator
Posts: 1267
Joined: Wed Dec 03, 2003 2:20 pm
Location: Toronto

Post by Stick » Wed Apr 09, 2008 7:42 pm

Stick wrote:currently on my 3rd xbox.. and even that one is starting to make strange noises.. i just hope that if it choses to die, it's still while i'm near the vicinity of where i can still get it serviced.
I should update this.


i'm now on my 4th xbox. lol

but i decided to pay a little more and trade it in for an elite. Luckily, they took the difference of the price I paid when the xbox was first released so I only paid a small sum in difference.

User avatar
Scott Hallett
Posts: 403
Joined: Wed Sep 06, 2006 6:59 pm
Location: Toronto
Contact:

Post by Scott Hallett » Thu Apr 10, 2008 4:38 am

Are you in the States or Canada? I tried to get them to update to the Elite here in Canada but they weren't having it...

User avatar
matt spangler
Posts: 469
Joined: Wed Dec 03, 2003 4:23 pm
Location: San Diego, CA
Contact:

Post by matt spangler » Thu Apr 10, 2008 8:23 am

so far so good for me, i have had mine since around november and it is a champ. Love the system!
See my stuff here:
http://www.mattspangler.com

Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests